Change the name of the CH_EXPENSE_ACCT, instead of "Charge Expense" - it must be named "Charge Account" - we're thinking to change just the name, not the columnname.
Create a migration script for the charges where CH_REVENUE_ACCT <> CH_EXPENSE_ACCT
The script must create a new charge for the revenue acct (in expense acct on the new charge, and (Revenue) added to the name) - and in the old charge make revenue=expense.
Move all the references of the old charge to the new charge, this is in documents: Bank, Cash, Inventory, Invoice, Payment - on the cases where the CH_Revenue_Acct is used. [If any document is reposted there must not be changes on the posting]
Change Doc_Bank, Doc_Cash, Doc_Inventory, Doc_Invoice and Doc_Payment to use just CH_Expense
Review process "Generate Charges" (I suppose nothing needs to be done there)
Change the accounting wiki page to reflect the new rules
Inactivate C_Charge.CH_Revenue.Acct column and field.
Search all CH_Revenue_Acct references in code (java, pl/sql and pl/pgsql) and fix it
thanks a lot , it's interest method. in my old database, table t_alter_column miss rule alter_column_rule.
Carlos Ruiz May 15, 2015 at 6:03 PM
the postgresql have the equivalent "INSERT INTO t_alter_column" for both cases.
Hiep Lq May 15, 2015 at 1:54 AM
also miss ALTER TABLE C_Charge_Acct MODIFY Ch_Revenue_Acct NUMBER(10) DEFAULT NULL ;
– Aug 17, 2012 9:40:13 AM COT ALTER TABLE C_Charge_Acct MODIFY Ch_Revenue_Acct NULL ;
Hiep Lq May 15, 2015 at 1:27 AM
Hi please help me confirm below issue, seem script in postgress is miss below command. oracle is ok. – Aug 17, 2012 9:39:05 AM COT ALTER TABLE C_AcctSchema_Default MODIFY Ch_Revenue_Acct NUMBER(10) DEFAULT NULL ;
– Aug 17, 2012 9:39:05 AM COT ALTER TABLE C_AcctSchema_Default MODIFY Ch_Revenue_Acct NULL ;
it make a old system after convert to idempiere will can't init a new client.
Brought from:
http://sourceforge.net/support/tracker.php?aid=2074649
_____________
As proposed in this thread:
http://sourceforge.net/forum/forum.php?thread_id=1930126&forum_id=611161
The plan is:
Change the name of the CH_EXPENSE_ACCT, instead of "Charge Expense" - it must be named "Charge Account" - we're thinking to change just the name, not the columnname.
Create a migration script for the charges where CH_REVENUE_ACCT <> CH_EXPENSE_ACCT
The script must create a new charge for the revenue acct (in expense acct on the new charge, and (Revenue) added to the name) - and in the old charge make revenue=expense.
Move all the references of the old charge to the new charge, this is in documents: Bank, Cash, Inventory, Invoice, Payment - on the cases where the CH_Revenue_Acct is used. [If any document is reposted there must not be changes on the posting]
Change Doc_Bank, Doc_Cash, Doc_Inventory, Doc_Invoice and Doc_Payment to use just CH_Expense
Review process "Generate Charges" (I suppose nothing needs to be done there)
Change the accounting wiki page to reflect the new rules
Inactivate C_Charge.CH_Revenue.Acct column and field.
Search all CH_Revenue_Acct references in code (java, pl/sql and pl/pgsql) and fix it
What do you think? Any further suggestion?
Regards,
Carlos Ruiz - globalqss
http://globalqss.com