autostarting plug-ins causes a lot of errors if 2Pack/AdempiereActivator is used

Description

I have a plug-in with a 2Pack. I want it to autostart with the swing client. If i set the start level to 6 or below, i get a bunch of errors caused by the activator. It seems that the pipo plug-ins are not ready at this time.
If i set the starting level to 7 or higher, the plug-in is never activated (even if i check the "activate this plug-in when one of its classes is loaded")

Carlos met the same problem. We would really appreciate a working solution.

Environment

None

Assignee

Heng Sin Low

Reporter

Jan Thielemann

Labels

None

Tested By

None

Components

Affects versions

Priority

Critical
Configure