update library (eclipse-4.17, jasper 6-15, jetty-9.4.33, atmosphere-2.6.4)

Description

Upgrade atmosphere to release 2.6.3

Environment

None

Activity

Show:
Heng Sin Low
October 27, 2020, 4:05 PM

if possible, we should just fix the osgi dependency (i.e make it optional) instead of stuck with old version. very likely you would have to do it eventually anyway, dues to potential security issues from old version.

Heng Sin Low
October 29, 2020, 8:37 AM

Hi ,

  1. Can you create a new wiki page to document the process to update the platform ?

  2. The build of atmosphere jar - is that an automated process ? if yes, it will be good if you share the project for that. If it is manual, it would be helpful you can share the steps of doing that in a wiki page.

Thanks, Low

Hiep Lq
October 29, 2020, 9:21 AM

actual document is on somewhere i will collect to wiki now
because due time for release 8.1 should i do build atmosphere manual document here
i plan to run org.idempiere.maven.to.p2 and push artifact to binary.file/p2.maven by github action

Heng Sin Low
October 31, 2020, 12:55 AM

Hi , the platform update break the fix from IDEMPIERE-4475, please fix, thanks.

Hiep Lq
October 31, 2020, 2:15 AM

hi

i fix on PR https://github.com/idempiere/idempiere/pull/335

on this PR also has
provide test bundle require to repository for use on offline
remove some unused bundle
sync launch

Assignee

Hiep Lq

Reporter

Heng Sin Low

Labels

None

Tested By

None

Components

Priority

Major
Configure