Report Column Set=>Report Column=>User Element List1 not displaying User1_ID values

Description

I would like to define financial report columns on the based of User Element List1 (User1_ID) but
Report Column Set=>Report Column=>Type=>User Element List1 does not display User1_ID for selection but GL account element values instead. Attached is a screenshot showing the issue.

Environment

None

Activity

Show:
Carlos Ruiz
March 8, 2018, 2:44 PM

Hi ,

This is not a bug, the User Element 1 is intended to show the element tree.

What you are expecting to use is maybe in User Column 1 - but I think is not possible actually to create a report filtered by that column as it's a wildcard column.

Regards,

Carlos Ruiz

Michael Powacht
March 9, 2018, 12:33 AM

Thanks Carlos, I'd like to clarify:
We do not use User Column 1 and user Column 2 at all but we use User Element List 1 and 2 throughout.
I agree User Element 1 and User Element 2 show the element tree. Since we use UEL 1 and UEL 2, there are not only 1 but 3 trees:

1.) Account Element(GL account)=>Tree type=Element value
2.) User1=>Tree type=User 1
3.) User2=>Tree type=User 2

In my column set, I expect the following condition to apply:

Column type=Segment Value

a.) if Type=Account, then dropdown values from Tree type=Element value (1.)
b.) if Type=User Element List 1, then dropdown values from Tree type=User 1 (2.)
c.) if Type=User Element List 2, then dropdown values from Tree type=User 2 (3.)

What do you think?

Michael

Carlos Ruiz
June 4, 2018, 11:45 AM

Hi , initially I didn't understand the issue, but now is clear.

Please check the fix at:
https://bitbucket.org/idempiere/idempiere/commits/bc1b757

Michael Powacht
June 4, 2018, 1:38 PM

thanks Carlos, tested and working as expected.

Assignee

Carlos Ruiz

Reporter

Michael Powacht

Labels

None

Tested By

None

Components

Affects versions

Priority

Minor
Configure