Field to show read-only grid (TrekGlobal contribution 1006181)

Description

We want to implement a new field type in core that can show a grid for a detail tab.

  • the field can admit and call callouts that would be triggered when a line of the grid is selected

  • the value to save in the field is the ID (converted to String) of the record selected, or a list of IDs separated by commas in the case of multi-selection (so, the String field must defined with enough space to save the mutliple IDs selected)

Our intention is to interact with this field via callouts, so a callout can potentially fill other fields on the master tab, and the master can have buttons that call a process to do things on the detail (this would be processing the list of IDs on the field).

Environment

None

Activity

Show:
Chuck Boecking
December 10, 2019, 9:01 PM

Adding search terms for future search: Single Selection Grid and Multiple Selection Grid

I had trouble finding this ticket. Chuck

Carlos Ruiz
March 24, 2019, 5:08 PM

fixed in zk 8.6.0.1

Carlos Ruiz
March 22, 2019, 6:23 PM

Reopened this ticket, as reported by at
https://groups.google.com/d/msg/idempiere/m_W-Sw5u4vs/bcIcQC_1AAAJ
this feature is broken in 6.2

From my tests with the packin uploaded above:

  • The window opens

  • The grids are there, with all the headers, data, etc - they can be seen using the inspect elements tool in chrome - but for some reason they are not visible

Until now my research -> It's possible some change in zk 8.6.0.1 broke it and it requires some tuning in the class GridTabSelectionListView

Carlos Ruiz
March 22, 2019, 6:19 PM

Adding here two files for test purposes:

  •  

  • - a 2pack that creates a new menu entry with name "Test New Grid Field"

  •  

  • - a patch to integrate temporarily in core for the test purposes of the window

Nicolas Micoud
December 21, 2016, 11:12 AM

Hi,
I'm currently migrating from 2.1 to 4.1 and i tested the migration scripts.

All updates of AD_Field.SeqNo cannot be applied as Now() is not a valid object (00904. 00000 - "%s: invalid identifier")
Did I miss something or does someone make a copy/paste from postgre to oracle ?

Thanks,

Nicolas

Fixed

Assignee

Heng Sin Low

Reporter

Carlos Ruiz

Labels

None

Tested By

None

Priority

Major