all stuff relate library of idempiere

Description

i already create some ticket relate update library. now i collect all to this ticket and implement at
https://bitbucket.org/idempiere/idempiere-experimental
+ remove version of dependency from bundle, if control version is requirement, do it at adempiere.cquery.

+ update library to newest version (jasper report, jetty, atmosphase, itext,....)

+ use osgi library if exists

+ set environment to java 8

Environment

None

Activity

Show:
Carlos Ruiz
January 4, 2017, 7:44 PM

Thanks , didn't notice your patch here - but I solved it similar with

Hiep Lq
February 10, 2017, 5:09 PM

new release of atmosphase have change api, so let idempiere can't build.
i add patch

to limit version to 2.x

Hiep Lq
February 10, 2017, 5:45 PM

i just try File_upload function of ckeditor, but it can't work on 4.1
reason: package import from fileupload is miss org.apache.commons.fileupload.disk
for fileupload, i think it's better to use bundle dependency than import package, so i just do

Hiep Lq
February 18, 2017, 2:57 AM

Hi Mr patch

will help update alpn more easy than current.

now to update alpn just do:
on source code:modify url.alpn.boot update date on org.adempiere.sdk-feature/materialize.properties
on produce server, just download new one and save it on root folder with name alpn-boot.jar

Carlos Ruiz
February 18, 2017, 8:28 AM

Thanks , that solved the issue.

Assignee

Hiep Lq

Reporter

Hiep Lq

Labels

Tested By

None

Affects versions

Priority

Major
Configure